Splits vertically one region in split crop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SplitRegionVertically( int regionIndex, double topPart, double bottomPart ) |
Visual Basic |
---|
Public Sub SplitRegionVertically ( _ regionIndex As Integer, _ topPart As Double, _ bottomPart As Double _ ) |
Visual C++ |
---|
public: void SplitRegionVertically( int regionIndex, double topPart, double bottomPart ) |
Parameters
- regionIndex
- Type: System..::..Int32
Index of region to be split vertically (numbering starts with 0).
- topPart
- Type: System..::..Double
Relative portion of the original region to become the new top region (0 to 1).
- bottomPart
- Type: System..::..Double
Relative portion of the original region to become the new bottom region (0 to 1).
Remarks
This function splits the crop into two regions: one occupying the top quarter of the crop, and the other the bottom quarter of the crop.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split horizontally. |