Test whether two shapes have equivalent definitions by comparing
the RebarShapeDefinition and MultiplanarDefinition properties.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsSameShapeIgnoringHooks( RebarShape otherShape ) |
Visual Basic |
---|
Public Function IsSameShapeIgnoringHooks ( _ otherShape As RebarShape _ ) As Boolean |
Visual C++ |
---|
public: bool IsSameShapeIgnoringHooks( RebarShape^ otherShape ) |
Parameters
- otherShape
- Type: Autodesk.Revit.DB.Structure..::..RebarShape
Another shape to be compared to this one.
Return Value
True if the shape definitions match, false otherwise.
Remarks
This method will return true if the definitions are exactly
equivalent, or if they are equivalent but have the opposite
start/end orientation.
Replaces the property RebarShape.SameShapeIgnoringHooks from prior releases.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |