Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static Surface Create( Curve profileCurve1, Curve profileCurve2 ) |
Visual Basic |
---|
Public Shared Function Create ( _ profileCurve1 As Curve, _ profileCurve2 As Curve _ ) As Surface |
Visual C++ |
---|
public: static Surface^ Create( Curve^ profileCurve1, Curve^ profileCurve2 ) |
Parameters
- profileCurve1
- Type: Autodesk.Revit.DB..::..Curve
The first profile curve; must be bounded and non-degenerate.
- profileCurve2
- Type: Autodesk.Revit.DB..::..Curve
The second profile curve; must be bounded and non-degenerate.
Return Value
The created surface. Note that this surface may not be of type RuledSurf.
Remarks
The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible
type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface.
Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
The curves should be such that a ruled surface whose rulings connect points on the two curves with the same
normalized coordinates has no self-intersections or interior singularities.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input profileCurve1 is not bound. -or- The profileCurve1 is degenerate (its length is too close to zero). -or- The input profileCurve2 is not bound. -or- The profileCurve2 is degenerate (its length is too close to zero). |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |