Multiplies this transformation by the specified transformation and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public Transform2D Multiply( Transform2D right ) |
Visual Basic |
---|
Public Function Multiply ( _ right As Transform2D _ ) As Transform2D |
Visual C++ |
---|
public: Transform2D^ Multiply( Transform2D^ right ) |
Parameters
- right
- Type: Autodesk.Revit.DB..::..Transform2D
Return Value
The transformation equal to the composition of the two transformations.
Remarks
The combined transformation has the same effect as applying the right transformation first, and this transformation, second.
So, denoting this transform by T1 and the right transform by T2, (T1(T2(p)) = (T1 * T2) (p).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |