Checks if the updater is enabled or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static bool IsUpdaterEnabled( UpdaterId id ) |
Visual Basic |
---|
Public Shared Function IsUpdaterEnabled ( _ id As UpdaterId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsUpdaterEnabled( UpdaterId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..UpdaterId
The updater id.
Return Value
Returns true if the updater is enabled, false otherwise.
Remarks
Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not
be executed regardless of its enable/disable status.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |