Gets a list of all segments of a given profile shape that define a given size.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public IList<ElementId> GetSharedSizes( double size, ConnectorProfileType shape ) |
Visual Basic |
---|
Public Function GetSharedSizes ( _ size As Double, _ shape As ConnectorProfileType _ ) As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetSharedSizes( double size, ConnectorProfileType shape ) |
Parameters
- size
- Type: System..::..Double
The size to search for.
- shape
- Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of segment object.
Return Value
A list of all segments that define a given size.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |