Checks if the tag type can be assigned to this multi-reference annotation type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsAllowedTagType( ElementId tagTypeId ) |
Visual Basic |
---|
Public Function IsAllowedTagType ( _ tagTypeId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsAllowedTagType( ElementId^ tagTypeId ) |
Parameters
- tagTypeId
- Type: Autodesk.Revit.DB..::..ElementId
The tag type to test.
Return Value
True if the tag type exclusively tags elements from the multi-reference annotation's reference category.
Remarks
Only tag types which exclusively tag elements from the multi-reference annotation's reference category can be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |