Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public Leader GetLeader( DatumEnds datumEnd, View view ) |
Visual Basic |
---|
Public Function GetLeader ( _ datumEnd As DatumEnds, _ view As View _ ) As Leader |
Visual C++ |
---|
public: Leader^ GetLeader( DatumEnds datumEnd, View^ view ) |
Parameters
- datumEnd
- Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
- view
- Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.
Return Value
The Leader of the datum plane. Null will return if no leader applied.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane has no leaders. |