Scales both the linear and translational parts of this transformation and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public Transform2D PostScale( double scale ) |
Visual Basic |
---|
Public Function PostScale ( _ scale As Double _ ) As Transform2D |
Visual C++ |
---|
public: Transform2D^ PostScale( double scale ) |
Parameters
- scale
- Type: System..::..Double
The scale value.
Return Value
Returns a pointer to "this" Transform2D.
Remarks
The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.