Creates a GUID from Revit project for given GUIDType.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static string CreateProjectLevelGUID( Document document, IFCProjectLevelGUIDType guidType ) |
Visual Basic |
---|
Public Shared Function CreateProjectLevelGUID ( _ document As Document, _ guidType As IFCProjectLevelGUIDType _ ) As String |
Visual C++ |
---|
public: static String^ CreateProjectLevelGUID( Document^ document, IFCProjectLevelGUIDType guidType ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- guidType
- Type: Autodesk.Revit.DB.IFC..::..IFCProjectLevelGUIDType
The GUID type.
Return Value
The guid string.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |