Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ReferenceIntersector( ICollection<ElementId> targetElementIds, FindReferenceTarget targetType, View3D view3d ) |
Visual Basic |
---|
Public Sub New ( _ targetElementIds As ICollection(Of ElementId), _ targetType As FindReferenceTarget, _ view3d As View3D _ ) |
Visual C++ |
---|
public: ReferenceIntersector( ICollection<ElementId^>^ targetElementIds, FindReferenceTarget targetType, View3D^ view3d ) |
Parameters
- targetElementIds
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The target element ids.
- targetType
- Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
- view3d
- Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Returns true if the view is not a view template. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |