Checks whether a given "from" position is valid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsAcceptableFromPosition( XYZ fromPosition ) |
Visual Basic |
---|
Public Function IsAcceptableFromPosition ( _ fromPosition As XYZ _ ) As Boolean |
Visual C++ |
---|
public: bool IsAcceptableFromPosition( XYZ^ fromPosition ) |
Parameters
- fromPosition
- Type: Autodesk.Revit.DB..::..XYZ
Return Value
True if the input is an acceptable "from" position and False otherwise.
Remarks
The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation
point will reverse the direction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |