Sets the world transformation that will be applied to geometry during rendering.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static void SetWorldTransform( Transform trf ) |
Visual Basic |
---|
Public Shared Sub SetWorldTransform ( _ trf As Transform _ ) |
Visual C++ |
---|
public: static void SetWorldTransform( Transform^ trf ) |
Parameters
- trf
- Type: Autodesk.Revit.DB..::..Transform
The transformation matrix.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |