Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public IList<FailureMessage> GetWarnings() |
Visual Basic |
---|
Public Function GetWarnings As IList(Of FailureMessage) |
Visual C++ |
---|
public: IList<FailureMessage^>^ GetWarnings() |
Return Value
List of failure messages representing warnings accumulated in the document.
Remarks
Function returns list of failure messages identical to the list displayed in a warning dialog when command
Manage tab->Inquiry pane->Review Warnings is issued through the UI. Operations performed on the returned list by the caller
do not impact information about warnings stored in the document.