A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool IsValidFaceId( BRepBuilderGeometryId faceId ) |
Visual Basic |
---|
Public Function IsValidFaceId ( _ faceId As BRepBuilderGeometryId _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidFaceId( BRepBuilderGeometryId^ faceId ) |
Parameters
- faceId
- Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Face id to be validated.
Return Value
True if faceId corresponds to a face previously added to this BRepBuilder, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |