Creates a new linear dimension object using the specified dimension style.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Dimension NewDimension( View view, Line line, ReferenceArray references, DimensionType dimensionType ) |
Visual Basic |
---|
Public Function NewDimension ( _ view As View, _ line As Line, _ references As ReferenceArray, _ dimensionType As DimensionType _ ) As Dimension |
Visual C++ |
---|
public: Dimension^ NewDimension( View^ view, Line^ line, ReferenceArray^ references, DimensionType^ dimensionType ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
- line
- Type: Autodesk.Revit.DB..::..Line
The line drawn for the dimension.
- references
- Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound.
- dimensionType
- Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.
Return Value
If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when references are not geometric references. |