A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ExportLinetypeInfo this[ ExportLinetypeKey linetypeKey ] { get; set; } |
Visual Basic |
---|
Public Default Property Item ( _ linetypeKey As ExportLinetypeKey _ ) As ExportLinetypeInfo Get Set |
Visual C++ |
---|
public: virtual property ExportLinetypeInfo^ default[ExportLinetypeKey^ linetypeKey] { ExportLinetypeInfo^ get (ExportLinetypeKey^ linetypeKey) sealed; void set (ExportLinetypeKey^ linetypeKey, ExportLinetypeInfo^ value) sealed; } |
Parameters
- linetypeKey
- Type: Autodesk.Revit.DB..::..ExportLinetypeKey
Return Value
A copy of the ExportLinetypeInfo.
Remarks
When getting this property, it returns a copy of the ExportLinetypeInfo from the table. In order to
make changes to the ExportLinetypeInfo and use those settings during export, set the modified
ExportLinetypeInfo back into the table using the same key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table. |