Checks if the reference category can be used with multi-reference annotations.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsAllowedReferenceCategory( ElementId referenceCategoryId ) |
Visual Basic |
---|
Public Function IsAllowedReferenceCategory ( _ referenceCategoryId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsAllowedReferenceCategory( ElementId^ referenceCategoryId ) |
Parameters
- referenceCategoryId
- Type: Autodesk.Revit.DB..::..ElementId
The reference category to check.
Return Value
True when the reference category can be used by multi-reference annotations.
Remarks
Only Structural Rebar is allowed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |