Set the mapping of fabrication part types for in-line parts for the service and group to change to.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018.2

Syntax

C#
public void SetMapOfInLinePartTypes(
	IDictionary<ElementId, ElementId> fabricationPartTypes
)
Visual Basic
Public Sub SetMapOfInLinePartTypes ( _
	fabricationPartTypes As IDictionary(Of ElementId, ElementId) _
)
Visual C++
public:
void SetMapOfInLinePartTypes(
	IDictionary<ElementId^, ElementId^>^ fabricationPartTypes
)

Parameters

fabricationPartTypes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'ElementId, ElementId>)>)>
The map containing the original fabrication part type to the fabrication part type to change to.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also