Adds a new items to the ComboBox.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public IList<ComboBoxMember> AddItems( IList<ComboBoxMemberData> memberData ) |
Visual Basic |
---|
Public Function AddItems ( _ memberData As IList(Of ComboBoxMemberData) _ ) As IList(Of ComboBoxMember) |
Visual C++ |
---|
public: IList<ComboBoxMember^>^ AddItems( IList<ComboBoxMemberData^>^ memberData ) |
Parameters
- memberData
- Type: System.Collections.Generic..::..IList<(Of <(<'ComboBoxMemberData>)>)>
An object list containing the data needed to construct the ComboBoxMember.
Return Value
The newly added ComboBoxMembers.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when memberData is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with memberData.Name already exists in the drop-down list. |