Validates if the given condition index is valid or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static bool IsValidConditionIndex( FabricationServiceButton button, int condition ) |
Visual Basic |
---|
Public Shared Function IsValidConditionIndex ( _ button As FabricationServiceButton, _ condition As Integer _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidConditionIndex( FabricationServiceButton^ button, int condition ) |
Parameters
- button
- Type: Autodesk.Revit.DB..::..FabricationServiceButton
The button to check.
- condition
- Type: System..::..Int32
The condition index.
Return Value
True if larger or equal to 0 and less than ConditionCount.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |