Gets the clip rectangle for the Revit view where rendering takes place. The clip rectangle
is the area currently being redrawn, which may be smaller than the view rectangle.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static Rectangle GetClipRectangle() |
Visual Basic |
---|
Public Shared Function GetClipRectangle As Rectangle |
Visual C++ |
---|
public: static Rectangle^ GetClipRectangle() |
Return Value
The clip rectangle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |