Add tab to option dialog with tab name and handler information.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void AddTab( string newTabName, TabbedDialogExtension tabbedDialogExtension ) |
Visual Basic |
---|
Public Sub AddTab ( _ newTabName As String, _ tabbedDialogExtension As TabbedDialogExtension _ ) |
Visual C++ |
---|
public: void AddTab( String^ newTabName, TabbedDialogExtension^ tabbedDialogExtension ) |
Parameters
- newTabName
- Type: System..::..String
The new tab page name.
- tabbedDialogExtension
- Type: Autodesk.Revit.UI..::..TabbedDialogExtension
The handlers information for the new tab page.
Remarks
There is a limit to the number of options page permitted in the dialog.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the limit of pages allowed in the Options dialog will be exceeded (99). |