Gets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public double GetOffsetForIntersectingReference(
	ElementId intersectingReference
)
Visual Basic
Public Function GetOffsetForIntersectingReference ( _
	intersectingReference As ElementId _
) As Double
Visual C++
public:
double GetOffsetForIntersectingReference(
	ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference to obtain offset value from.

Return Value

The offset for the intersecting reference

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also