Retrieves or changes the wall's designated structural usage.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public StructuralWallUsage StructuralUsage { get; set; } |
Visual Basic |
---|
Public Property StructuralUsage As StructuralWallUsage Get Set |
Visual C++ |
---|
public: property StructuralWallUsage StructuralUsage { StructuralWallUsage get (); void set (StructuralWallUsage value); } |
Field Value
The wall's designated structural usage, such as bearing or non bearing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for StructuralWallUsage. -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration |