Changes the double-click action associated with a specified target.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SetAction( DoubleClickTarget target, DoubleClickAction action ) |
Visual Basic |
---|
Public Sub SetAction ( _ target As DoubleClickTarget, _ action As DoubleClickAction _ ) |
Visual C++ |
---|
public: void SetAction( DoubleClickTarget target, DoubleClickAction action ) |
Parameters
- target
- Type: Autodesk.Revit.UI..::..DoubleClickTarget
The double-click target whose action will be changed.
- action
- Type: Autodesk.Revit.UI..::..DoubleClickAction
The action to assign to the target.
Remarks
This change will be stored in the user's profile and will affect future sessions of Revit in
addition to the current session.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The specified action is not valid for the target element. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |