The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public double RightAnnotationCropOffset { get; set; } |
Visual Basic |
---|
Public Property RightAnnotationCropOffset As Double Get Set |
Visual C++ |
---|
public: property double RightAnnotationCropOffset { double get (); void set (double value); } |
Remarks
This value must be a non-negative length in view units.
Default value is 1/12' (1"), minimal value is 1/96' (1/8").
To get offset in model units, multiply the value by the view scale.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to have an annotation crop. |