Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public virtual IFCData Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As IFCData
	Get
Visual C++
public:
virtual property IFCData^ Current {
	IFCData^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException There is no current item in the iterator.

See Also