Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function NewFoundationSlab ( _
profile As CurveArray, _
floorType As FloorType, _
level As Level, _
structural As Boolean, _
normal As XYZ _
) As Floor |
Parameters
- profile
- Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
- floorType
- Type: Autodesk.Revit.DB..::..FloorType
A floor type to be used by the new floor instead of the default type.
- level
- Type: Autodesk.Revit.DB..::..Level
The level on which the floor is to be placed.
- structural
- Type: System..::..Boolean
If set, specifies that the floor is structural in nature.
- normal
- Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered
to be upper and down.
Return Value
if successful, a new foundation slab object within the project, otherwise
nullNothingnullptra null reference (Nothing in Visual Basic).
Remarks
Exceptions
See Also