Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline,
with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public BoundingBoxIsInsideFilter(
Outline outline,
bool inverted
) |
Visual Basic |
---|
Public Sub New ( _
outline As Outline, _
inverted As Boolean _
) |
Visual C++ |
---|
public:
BoundingBoxIsInsideFilter(
Outline^ outline,
bool inverted
) |
Parameters
- outline
- Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
- inverted
- Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.
Exceptions
See Also