This function should define all handles that the Rebar has. This function is called when the Rebar is created.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
bool GetCustomHandles( RebarHandlesData handlesInfoData ) |
Visual Basic |
---|
Function GetCustomHandles ( _ handlesInfoData As RebarHandlesData _ ) As Boolean |
Visual C++ |
---|
bool GetCustomHandles( RebarHandlesData^ handlesInfoData ) |
Parameters
- handlesInfoData
- Type: Autodesk.Revit.DB.Structure..::..RebarHandlesData
Use the methods on this class to define the handles for the free form rebar. Revit will use these handles to create appropriate RebarConstraints.
Return Value
Returns true if the handles were defined successfully, false otherwise.
Remarks
Revit consider the execution failed if we have duplicate tags for custom, start and end handles.