Tests the type id to make sure it satisfies the following conditions
It is a valid element id.It corresponds to a valid DirectShapeType.The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid.
The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public bool IsValidTypeId(
ElementId typeId
) |
Visual Basic |
---|
Public Function IsValidTypeId ( _
typeId As ElementId _
) As Boolean |
Visual C++ |
---|
public:
bool IsValidTypeId(
ElementId^ typeId
) |
Return Value
False unless typeId satisfies the conditions listed above and the type id of this object was not set previously.
Exceptions
See Also