Adds an element to the aggregate.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void Add( IFCData ifcData ) |
Visual Basic |
---|
Public Sub Add ( _ ifcData As IFCData _ ) |
Visual C++ |
---|
public: void Add( IFCData^ ifcData ) |
Parameters
- ifcData
- Type: Autodesk.Revit.DB.IFC..::..IFCData
The IFCData element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The aggregate is not valid. |