Gets a collection of elements from which this Part is created by the PartMaker.
May return more than one source only if there is merge involved somewhere in the history of this Part.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ICollection<LinkElementId> GetSourceElementIds() |
Visual Basic |
---|
Public Function GetSourceElementIds As ICollection(Of LinkElementId) |
Visual C++ |
---|
public: ICollection<LinkElementId^>^ GetSourceElementIds() |
Return Value
The collection of elements
Remarks
A source element is one of the elements in the original file that the PartMaker uses to create a Part.
For example, a floor or a wall used to create a Part can be called a source element.