A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool IsValidEdgeId( BRepBuilderGeometryId edgeId ) |
Visual Basic |
---|
Public Function IsValidEdgeId ( _ edgeId As BRepBuilderGeometryId _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidEdgeId( BRepBuilderGeometryId^ edgeId ) |
Parameters
- edgeId
- Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Edge id to be validated.
Return Value
True if edgeId corresponds to an edge previously added to this BRepBuilder, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |