Creates a new railing by specifying the railing path in the project document.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static Railing Create( Document document, CurveLoop curveLoop, ElementId railingTypeId, ElementId baseLevelId ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ curveLoop As CurveLoop, _ railingTypeId As ElementId, _ baseLevelId As ElementId _ ) As Railing |
Visual C++ |
---|
public: static Railing^ Create( Document^ document, CurveLoop^ curveLoop, ElementId^ railingTypeId, ElementId^ baseLevelId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- curveLoop
- Type: Autodesk.Revit.DB..::..CurveLoop
The railing path along which the new railing will be created. The curveLoop should be continuous with curves which are only bounded lines and arcs on the same horizontal plane. It also has to have maximum two curves meet in one end point.
- railingTypeId
- Type: Autodesk.Revit.DB..::..ElementId
The railing type of the new railing to be created.
- baseLevelId
- Type: Autodesk.Revit.DB..::..ElementId
The base level on which the new railing will be created.
Return Value
The new railing instance if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The curveLoop must be a single connected path, located on the same horizontal plane and defined using lines or arcs only. It also has to have maximum two curves meet in one end point. -or- The railingTypeId is not a railing type. -or- The ElementId baseLevelId is not a Level. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |