Provides access to an object that represents the currently active project.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual UIDocument ActiveUIDocument { get; } |
Visual Basic |
---|
Public Overridable ReadOnly Property ActiveUIDocument As UIDocument Get |
Visual C++ |
---|
public: virtual property UIDocument^ ActiveUIDocument { UIDocument^ get (); } |
Remarks
External API commands can access this property in read-only mode only!
The ability to modify the property is reserved for future implementations.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to modify the property. |