Check whether a geometry reference
corresponds to a referenceable plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static bool IsValidPlaneReference( Document doc, Reference planeReference ) |
Visual Basic |
---|
Public Shared Function IsValidPlaneReference ( _ doc As Document, _ planeReference As Reference _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidPlaneReference( Document^ doc, Reference^ planeReference ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
- planeReference
- Type: Autodesk.Revit.DB..::..Reference
Remarks
Valid plane references include: planar faces
of solids; the PlaneReference properties of
Level and
SketchPlane;
the Reference property of
ReferencePlane.