Define a ReferencePoint relative to a planar reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class PointOnPlane : PointElementReference |
Visual Basic |
---|
Public Class PointOnPlane _ Inherits PointElementReference |
Visual C++ |
---|
public ref class PointOnPlane : public PointElementReference |
Remarks
A ReferencePoint on a plane has its X and Y
basis vectors parallel to the plane, but is free to rotate
around its Z basis vector. It can lie on the plane
or have an offset.