Checks to see if the fabrication part type exists on one of the button conditions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Release
Syntax
C# |
---|
public bool ContainsFabricationPartType( FabricationPartType partType ) |
Visual Basic |
---|
Public Function ContainsFabricationPartType ( _ partType As FabricationPartType _ ) As Boolean |
Visual C++ |
---|
public: bool ContainsFabricationPartType( FabricationPartType^ partType ) |
Parameters
- partType
- Type: Autodesk.Revit.DB..::..FabricationPartType
The fabrication part type to check.
Return Value
Returns true if the fabrication part type exists on the fabrication service button.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |