Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction)
until the end of the next transaction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public FailureHandlingOptions SetDelayedMiniWarnings( bool bFlag ) |
Visual Basic |
---|
Public Function SetDelayedMiniWarnings ( _ bFlag As Boolean _ ) As FailureHandlingOptions |
Visual C++ |
---|
public: FailureHandlingOptions^ SetDelayedMiniWarnings( bool bFlag ) |
Parameters
- bFlag
- Type: System..::..Boolean
True to delay the display of the mini-warning dialog until the end of the next transation, false to display them as this transaction is completed.
Return Value
This FailureHandlingOptions object.
Remarks
This controls warnings suitable for the mini-warnings dialog only. If the modal flag is set to true
with SetForcedModalHandling(Boolean) then this flag will be ignored.