Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public FailureHandlingOptions SetForcedModalHandling( bool bFlag ) |
Visual Basic |
---|
Public Function SetForcedModalHandling ( _ bFlag As Boolean _ ) As FailureHandlingOptions |
Visual C++ |
---|
public: FailureHandlingOptions^ SetForcedModalHandling( bool bFlag ) |
Parameters
- bFlag
- Type: System..::..Boolean
True to force Revit to use a modal error dialog, false to allow a non-blocking dialog for warnings resulting from this transaction.