Returns the index of the layer just below the core boundary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public int GetCoreBoundaryLayerIndex(
ShellLayerType shellLayerType
) |
Visual Basic |
---|
Public Function GetCoreBoundaryLayerIndex ( _
shellLayerType As ShellLayerType _
) As Integer |
Visual C++ |
---|
public:
int GetCoreBoundaryLayerIndex(
ShellLayerType shellLayerType
) |
Parameters
- shellLayerType
- Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType.Exterior return the index on the exterior side (or top side for a roof, floor, or ceiling type).
If ShellLayerType.Interior return the index on the interior side (or bottom side for a roof, floor, or ceiling type).
Return Value
The index of the layer.
Remarks
Exceptions
See Also