Inserts multiple VertexStreamPosition instances into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public void AddVertices(
	IList<VertexPosition> vertices
)
Visual Basic
Public Sub AddVertices ( _
	vertices As IList(Of VertexPosition) _
)
Visual C++
public:
void AddVertices(
	IList<VertexPosition^>^ vertices
)

Parameters

vertices
Type: System.Collections.Generic..::..IList<(Of <(<'VertexPosition>)>)>
The vertices to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also