The real number that represents the scale of the conformal transformation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public double Scale { get; } |
Visual Basic |
---|
Public ReadOnly Property Scale As Double Get |
Visual C++ |
---|
public: property double Scale { double get (); } |
Remarks
When the transformation is conformal and can be decomposed as the product of a rigid-body motion,
uniform scale and reflection, this property returns the scale value of the uniform scale transformation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This transformation is not conformal and the scale is undefined. |