Zoom the view.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void Zoom( double zoomFactor ) |
Visual Basic |
---|
Public Sub Zoom ( _ zoomFactor As Double _ ) |
Visual C++ |
---|
public: void Zoom( double zoomFactor ) |
Parameters
- zoomFactor
- Type: System..::..Double
Factor by which to zoom in or out. Values greater than 1 zooms in, less than 1 zooms out.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | zoomFactor is not positive. |