Assigns scan override settings to the whole PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void SetPointCloudScanOverrideSettings( ElementId elementId, PointCloudOverrideSettings newSettings ) |
Visual Basic |
---|
Public Sub SetPointCloudScanOverrideSettings ( _ elementId As ElementId, _ newSettings As PointCloudOverrideSettings _ ) |
Visual C++ |
---|
public: void SetPointCloudScanOverrideSettings( ElementId^ elementId, PointCloudOverrideSettings^ newSettings ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the element to be overridden.
- newSettings
- Type: Autodesk.Revit.DB.PointClouds..::..PointCloudOverrideSettings
Override settings to be assigned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |