Associate a single CoverType with all exposed faces of the host element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetCommonCoverType( RebarCoverType coverType ) |
Visual Basic |
---|
Public Sub SetCommonCoverType ( _ coverType As RebarCoverType _ ) |
Visual C++ |
---|
public: void SetCommonCoverType( RebarCoverType^ coverType ) |
Parameters
- coverType
- Type: Autodesk.Revit.DB.Structure..::..RebarCoverType
A CoverType object to be applied to all faces.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |