Creates an object representing element or subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public static Subelement Create( Document aDoc, Reference reference ) |
Visual Basic |
---|
Public Shared Function Create ( _ aDoc As Document, _ reference As Reference _ ) As Subelement |
Visual C++ |
---|
public: static Subelement^ Create( Document^ aDoc, Reference^ reference ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document.
- reference
- Type: Autodesk.Revit.DB..::..Reference
The reference that identifies element or subelement.
Return Value
The newly created subelement.
Remarks
If %reference% points to linked document:
- The GetReference()()()() method of the newly created subelement will return the local reference in the linked document.
- The Document property of the newly created subelement will return the linked document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | reference does not identify a valid element or subelement. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |