Create a new instance of a Rebar Shape, which defines the shape of a rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
A document to contain the RebarShape.
- definition
- Type: Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
The definition of the rebar shape, as a set of curves in a plane
driven by parameters.
- multiplanarDefinition
- Type: Autodesk.Revit.DB.Structure..::..RebarShapeMultiplanarDefinition
If not null, the created RebarShape will be a 3D shape. The shape
is built out of the planar RebarShapeDefinition, with additional
out-of-plane segments defined by the RebarShapeMultiplanarDefinition
object. Not supported in conjunction with RebarShapeDefinitionByArc
of type Spiral or LappedCircle.
- style
- Type: Autodesk.Revit.DB.Structure..::..RebarStyle
Whether the shape is to be used as a standard bar or a stirrup/tie.
- attachmentType
- Type: Autodesk.Revit.DB.Structure..::..StirrupTieAttachmentType
When the style is stirrup/tie, specify whether it will attach to the
interior of cover (cover is measured to the stirrups), or to the
exterior of cover (cover is measured to the standard bars).
Ignored when the style is Standard.
- startHookAngle
- Type: System..::..Int32
The start hook angle, expressed as an integral number of degrees.
If 0, the shape will have no start hook. Common values are 0, 90, 135, and 180.
- startHookOrientation
- Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
The orientation of the start hook.
Ignored when startHookAngle is 0.
- endHookAngle
- Type: System..::..Int32
The end hook angle, expressed as an integral number of degrees.
If 0, the shape will have no end hook. Common values are 0, 90, 135, and 180.
- endHookOrientation
- Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
The orientation of the end hook.
Ignored when endHookAngle is 0.
- higherEnd
- Type: System..::..Int32
When the rebar crosses itself, one end will be "lifted" to avoid self-intersection.
Specify which end should be lifted: 0 for start, 1 for end.
Return Value
A new RebarShape instance.
Exceptions
See Also